Back to overview
Downtime
MTK Network error
Mar 19, 2026 at 09:00pm UTC
Affected services
Home Assistant MTK
Kitsos DNS 04
Kitsos Network MTK
Resolved
Mar 20, 2026 at 02:50pm UTC
Everything should be working fine again.
Affected services
Updated
Mar 20, 2026 at 02:30pm UTC
Problem resolved. We are currently monitoring if everything is working again.
Affected services
Updated
Mar 20, 2026 at 02:20pm UTC
Problem identified. We are working on a fix.
Affected services
Created
Mar 19, 2026 at 09:00pm UTC
The internet at MTK is not available due to a router error.
The following services are affected
- Home Assistant MTK (remote access)
- Apple Home (remote access)
- MTK Network
- Kitsos DNS 04
Affected services