Back to overview
Resolved

Kitsos CDN 2 is down

Jun 12, 2026 at 1:31pm UTC
Affected services
Kitsos CDN 2

Resolved
Jun 12, 2026 at 1:42pm UTC

The fix has been implemented and Kitsos CDN 2 should be working normal again.

Updated
Jun 12, 2026 at 1:35pm UTC

We have identified the cause of this issue and are working on a fix.
Kitsos CDN 1 and Kitsos CDN 3 are working normally.

Created
Jun 12, 2026 at 1:31pm UTC

Kitsos CDN 2 went down. Kitsos CDN 1 and Kitsos CDN 3 are working normally.