Back to overview
Resolved
Kitsos CDN 1 Outage
Jun 18, 2026 at 8:17pm UTC
Affected services
Kitsos CDN
Resolved
Jun 19, 2026 at 6:06am UTC
We have implemented a fix and everything should be working normally again. The outage was caused by a configuration error in our deployment process. We apologize for any inconvenience.
Affected services
Updated
Jun 19, 2026 at 6:00am UTC
We have identified the cause and are working on a fix. Kitsos CDN 2 and Kitsos CDN 3 are working normally.
Affected services
Created
Jun 18, 2026 at 8:17pm UTC
Kitsos CDN went down. Kitsos CDN 2 und Kitsos CDN 3 are working normally.
Affected services