Back to overview
Resolved

Outage at Kitsos MTK Location

Jun 19, 2026 at 10:30am UTC
Affected services
Home Assistant MTK
Athena DNS
Kitsos Network MTK

Resolved
Jun 19, 2026 at 1:37pm UTC

The reason for this incident was an internet outage at the Kitsos MTK Location caused by the ISP. We apologize for any inconvenience.

Updated
Jun 19, 2026 at 1:27pm UTC

All services are working normally again. We apologize for any inconvenience. We are still investigating the cause of this incident and will publish a statement shortly.

Updated
Jun 19, 2026 at 1:23pm UTC

Kitsos Athena DNS should be working normally again. We are already implementing a fix for Home Assistant MTK and it should be working again soon.

Updated
Jun 19, 2026 at 11:00am UTC

The Kitsos Network MTK should be working normally again. Kitsos Athena DNS and Home Assistant MTK are still experiencing issues.

Created
Jun 19, 2026 at 10:30am UTC

We are experiencing a network outage at our MTK location. The following services are also affected by this outage:
- Kitsos Athena DNS
- Kitsos Home Assistant MTK