Back to overview
Resolved

Kitsos Utility API outage

Jul 28, 2026 at 2:55pm UTC
Affected services
Kitsos Utility API

Resolved
Jul 29, 2026 at 12:00am UTC

The incident is resolved, and our Utility API is working normally again.

The outage was caused by a controlled stress test carried out on our own infrastructure to identify weaknesses in how the system handles unusually high request volumes. The test uncovered an issue that could temporarily affect availability under heavy load.

The underlying vulnerability has now been fixed, and additional safeguards and rate-limiting measures have been implemented to prevent similar incidents in the future.

As the API is still in beta, occasional issues may occur while we continue testing and improving its stability, security, and performance.

We apologize for the disruption and appreciate your understanding.

Created
Jul 28, 2026 at 2:55pm UTC

Our Kitsos Utility API is currently unavailable due to ongoing system tests. All requests are failing with an Internal Server Error.

We expect the incident to be resolved by midnight UTC. Further details will be provided once the incident has been resolved.

We apologize for the disruption.